月度归档:2009年08月

Palindrome pku1159 回文字符串

【代码】

package pku1159;
 
/* 动态规划   状态转移方程如下:
d[i][j] = 0 (i >= j) :
d[i][j]=a[i + 1][j - 1] (ch[i] == ch[j]);
d[i][j]=min(a[i + 1)[j], a[i][j - 1]) + 1 (ch[i] != ch[j]);
*/
import java.util.*;
public class Main {
 
public static void main(String[] args) {
   Scanner cin = new Scanner(System.in);
   int n;
   n = cin.nextInt();
   String str = cin.next();
   short[][] a = new short[n + 1][n + 1];
   for (int i = n - 1; i >= 0; i--){
    for (int j = 0; j < n; j++){
     if ( i < j){
      if (str.charAt(i) == str.charAt(j))
       a[i][j] = a[i+ 1][j -1];
      else{
       a[i][j] =a[i + 1][j] < a[i][j - 1]?a[i + 1][j]:a[i][j - 1];
       a[i][j]++;
      }
 
     }
    }
   }
   System.out.println(a[0][n - 1]);
}
 
}

Windows下PHP环境配置的问题

         自从Windows7发布测试版后,一直作为小白鼠在用着,界面和用户体验都不错,但是一段时间后发现使用Xampp搭建的PHP环境运行起来暴慢,今天终于不能再忍受了,于是把Xampp给卸载了,使用手工安装的环境,但是“涛声依旧”。Google了一上,说是32位机与64位的问题,貌似系统是32的w7,奇怪了!

        最后不得已,重新安装了XP,手动安装PHP环境,但是在安装的过程中出现了如下几个问题:

        1、  关于短符号,即是否允许使用<? ?>,在现在使用的模块类中,生成的代码是以短符号包含PHP代码的,导致无法加载文件。

        2、  关于扩展地址,即extension_dir,默认情况下是”./”,这个是必须要改的。

        3、  php_mysql.dll扩展,在扩展地址和apache配置安装完成后,可以运行PHP了,但是发现在apache的错误日志显示PHP Warning:  PHP Startup: Unable to load dynamic library ‘D:/work/php/ext/php_mysql.dll,在phpinfo()显示的扩展中并没有mysql,google下发现是某些扩展需要一些在system32中添加动态链接库,mysql和mysqli在PHP >= 5.0.0 需要 libmysql.dll

        4、  与3类似,显示PHP Warning:  PHP Startup: Unable to load dynamic library ‘D:/work/php/ext/php_curl.dll’ 。curl函数库需要libeay32.dll,ssleay32.dll,解决方法:把php目录下的这两个文件拷贝到system32下即可。其它详细信息请移步Windows 下安装扩展库

滑雪 pku1088 动态规划

【Description】
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子

1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-…-3-2-1更长。事实上,这是最长的一条。

【Input】
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。 【Output】 输出最长区域的长度。 【Sample Input】 5 5 1 2 3 4 5 16 17 18 19 6 15 24 25 20 7 14 23 22 21 8 13 12 11 10 9 【Sample Output】 25 【Source】 SHTSC 2002

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
package pku1088;
 
/**深度搜索+备忘录方法 / 动态规划   参考了pku牛人的解题报告*/
import java.util.*;
 
public class Main {
 
/**
   * @param args
   */
private static int[][] a = new int[101][101];
 
private static int[][] b = new int[101][101];// 备忘录
 
private static boolean[][] flag = new boolean[101][101];
 
private static int r, c;
 
private static int[] tempx = { 1, 0, -1, 0 };
 
private static int[] tempy = { 0, -1, 0, 1 };
 
public static int trydo(int x, int y) {
   if (flag[x][y])// 如果已经有了,直接输出,备忘录方法快就快在这里
    return b[x][y];
   int max = 1, temp;
   for (int i = 0; i < 4; i++) {// 四个方向
    int xx = x + tempx[i];
    int yy = y + tempy[i];
    if (xx >= 0 && xx < r && yy >= 0 && yy < c) {// 判断是否出界                                                           
     if (a[xx][yy] < a[x][y]) {// 如果要到的点到本点低
      temp = trydo(xx, yy);// 走下一个点
      if (temp + 1 > max)//
       max = temp + 1;
     }
    }
   }
   flag[x][y] = true;// 已经走过
   b[x][y] = max;// 存入备忘录
   return max;
 
}
 
public static void main(String[] args) {                                 
   // TODO Auto-generated method stub
   Scanner cin = new Scanner(System.in);
   r = cin.nextInt();
   c = cin.nextInt();
   for (int i = 0; i < r; i++) {
    for (int j = 0; j < c; j++) {
     a[i][j] = cin.nextInt();
     b[i][j] = 0;
     flag[i][j] = false;
    }
   }
   int max = 0;
   for (int i = 0; i < r; i++) {// 生成每个点的最大
    for (int j = 0; j < c; j++) {
     if (trydo(i, j) > max)
      max = trydo(i, j);
    }
   }
   System.out.println(max);
}
 
}